Printing the Paper Copy

From APL
Revision as of 12:25, 22 April 2019 by Aplstudent (talk | contribs) (Creating Files to Print)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Negative or Positive, Mirrored or Not Mirrored

We need to determine if the paper copy should be the negative (color inverted) or positive (color not inverted) of the layer's digital image. The PCB process leaves copper in the unexposed areas (i.e. the black ink areas on the film = copper areas on the PCB) so we ultimately want the film to be the positive of our digital layer. Although, the film takes the negative image of the paper during the transition from paper to film. Thus, we want to print a negative image on paper so the film will show the positive.

We also want to make sure that when we expose the top and bottom layers everything lines up. This means we need to print the the top layer as a regular image and the bottom layer as a mirrored image.

Creating Files to Print

To create a SVG (Scalable Vector Graphic) of a schematic in KiCad open Pcbnew and select File -> Export SVG. Next, select the front copper layer (F.Cu) or back copper layer (B.Cu). If you are converting the front copper layer do not mirror the image, but if you are printing the back copper layer, select "Print mirrored". Once you've chosen a location to save the files (the "Output Directory") select plot for each layer with the appropriate settings (mirrored or not mirrored).

Now, with your SVG files saved somewhere accessible we'll want to create negatives of the images. Unfortunately, printing a PNG or SVG of a negative can be surprisingly troublesome. The main issue is that a PNG or SVG contains black, white, and transparent regions and the transparent areas, which print as white, will not turn black when creating a negative image. The fix is to print the PNG or SVG on top of a black rectangle the size of your PCB. To do this we'll use a program like photoshop, GIMP, or Inkscape to create two digital layers, one top layer with the PCB schematic and one bottom layer with a black rectangle.

(Both GIMP and Inkscape can be found on the "Hank" computer in the APL or downloaded for free, in this tutorial we'll use Inkscape)

Open Inkscape and select File -> Open..., find your SVG images and select "Open". Once you're schematic is loaded we'll want to add the SVG images to a layer. First create a blank layer by selecting Layer -> Add Layer.. then click Add. Now, use the mouse tool to click and drag a selection box around you're schematic. Once you have everything in your schematic selected right click somewhere in the selection box and click "Move to layer ...". Select the layer you just created and click "Move". This will enable you to create a second layer below your schematic layer and draw a black background. Now, create a new layer the same way we created the first layer but in the popup menu select "Position: Below current". Open the Layers... meun by pressing Shift+Ctrl+L and select your first layer (the one with your schematic). Next click Extensions -> Color -> Negative to create a negative image. You'll notice that most of the detail in your schematic disappears. To get this detail back, select your second layer and use the "Create rectangles and squares" tool (make sure black is selected from the row of colors at the bottom of the screen) to draw a large black rectangle around you circuit. To avoid wasting ink don't fill the entire page with the black rectangle, just fill the area of the page that contains the PCB schematic. When you're finished if everything went correctly the areas of the board we want to be copper should be white and everything else should be black.

Before you're ready to print you'll want to make sure the page size matches the printer paper. This can be done in inkscape by holding Ctrl+Shift+D to open the document properties. Now select the "Page Size", this will most likely be 8.5 x 11 inches. Now make sure everything fits on the page. Do not rescale any of the PCB elements, only move them. The scale of the PCB must match the original scale of your schematic.

Finally, you'll want to create a PDF or PNG copy of your SVG negatives. This can be done in Inkscape by changing the settings in File -> Save As... section. This PDF or PNG can be emailed to the UO "Campus Copy" to be printed with a high resolution printer on #28 photo paper. Alternatively, if you have access to one, a 1200 dpi printer will be sufficient.