Gerbview

From APL
Jump to: navigation, search

Open Gerbview from the KiCad startup window by selecting Tools -> Run Gerbview. Gerbview is a useful way to check that all the layers of your PCB are properly aligned. While using Gerbview isn't strictly necessary it is good practice to double check your work here and is a useful program for printing your files.

Uploading Gerber and Drill Files

To upload a Gerber file select File -> Load Gerber File, then, navigate to the "Gerbers" file you made in Pcbnew. Now, open the "Gerbers" file and select all the files. The files should have suffixes like .gto, .gts, .gtl, etc. and will indicate which PCB layer they are associated with. Now, to open the drill files select File -> Load EXCELLON Drill File and again navigate to the "Gerbers" folder, but select any files with the .drl suffix.

Checking Your Layers

On the right side of the the Gerbview window you should see all your layers listed with green diamonds next to them. At this point you should go through your layers, check and uncheck different groups of layers to make sure everything is aligned properly. If your board looks correct you are finished. If there are errors, go back to Pcbnew and correct your mistakes. If you make changes in Pcbnew you will need to delete your old Gerber and drill files and plot new ones.

Return to How to Make a Printed Circuit Board (PCB)